From 230c9b7b9418456aa12e7783227cd330b2170f2c Mon Sep 17 00:00:00 2001
From: Manuel <git@huesers.de>
Date: Tue, 11 Mar 2025 21:15:22 +0100
Subject: [PATCH] Update makepkg.conf

* Include latest upstream changes
---
 makepkg.conf | 47 ++++++++++++++++++++++++++++++++++++++++-------
 1 file changed, 40 insertions(+), 7 deletions(-)

diff --git a/makepkg.conf b/makepkg.conf
index eb74a7c..ee6b4b4 100644
--- a/makepkg.conf
+++ b/makepkg.conf
@@ -45,15 +45,12 @@ CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
 LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now \
          -Wl,-z,pack-relative-relocs"
 LTOFLAGS="-flto=auto -falign-functions=32"
-
-RUSTFLAGS="-Copt-level=3 -Ctarget-cpu=x86-64-v3 -Clink-arg=-z -Clink-arg=pack-relative-relocs -Ccodegen-units=1"
 #-- Make Flags: change this for DistCC/SMP systems
 
 MAKEFLAGS="-j $(nproc)"
 #-- Debugging flags
 DEBUG_CFLAGS="-g"
 DEBUG_CXXFLAGS="$DEBUG_CFLAGS"
-DEBUG_RUSTFLAGS="-C debuginfo=2"
 
 #########################################################################
 # BUILD ENVIRONMENT
@@ -68,7 +65,7 @@ DEBUG_RUSTFLAGS="-C debuginfo=2"
 #-- check:    Run the check() function if present in the PKGBUILD
 #-- sign:     Generate PGP signature file
 #
-BUILDENV=(!distcc color !ccache check !sign)
+BUILDENV=(!distcc !color !ccache check !sign)
 #
 #-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
 #-- specify a space-delimited list of hosts running in the DistCC cluster.
@@ -165,10 +162,46 @@ SRCEXT='.src.tar.gz'
 #-- Command used to run pacman as root, instead of trying sudo and su
 #PACMAN_AUTH=()
 # vim: set ft=sh ts=2 sw=2 et:
+#!/hint/bash
+#
+# /etc/makepkg.conf.d/fortran.conf
+#
+
+#########################################################################
+# FORTRAN LANGUAGE SUPPORT
+#########################################################################
+
+# Flags used for the Fortran compiler, similar in spirit to CFLAGS. Read
+# linkman:gfortran[1] for more details on the available flags.
+FFLAGS="-O3 -pipe -march=x86-64-v3"
+
+FCFLAGS="$FFLAGS"
+
+# Additional compiler flags appended to `FFLAGS` and `FCFLAGS` for use in debugging. Usually
+# this would include: ``-g''. Read linkman:gfortran[1] for more details on the wide
+# variety of compiler flags available.
+#DEBUG_FFLAGS="-g"
+#!/hint/bash
+# shellcheck disable=2034
+
+#
+# /etc/makepkg.conf.d/rust.conf
+#
+
+#########################################################################
+# RUST LANGUAGE SUPPORT
+#########################################################################
+
+# Flags used for the Rust compiler, similar in spirit to CFLAGS. Read
+# linkman:rustc[1] for more details on the available flags.
+RUSTFLAGS="-Cforce-frame-pointers=yes -Copt-level=3 -Ctarget-cpu=x86-64-v3 -Clink-arg=-z -Clink-arg=pack-relative-relocs -Ccodegen-units=1"
+
+# Additional compiler flags appended to `RUSTFLAGS` for use in debugging.
+# Usually this would include: ``-C debuginfo=2''. Read linkman:rustc[1] for
+# more details on the available flags.
+DEBUG_RUSTFLAGS="-C debuginfo=2"
 
-export KCPPFLAGS=" -march=x86-64-v3 -O3"
-export FFLAGS=$CFLAGS
 export KCFLAGS=" -march=x86-64-v3 -O3"
-export FCFLAGS=$CFLAGS
 export GOAMD64=v3
+export KCPPFLAGS=" -march=x86-64-v3 -O3"
 export CARGO_PROFILE_RELEASE_LTO=fat