From 9929452faae7f459006f7823594be8049f8b152e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Manuel=20H=C3=BCsers?= <aur@huesers.de>
Date: Sat, 1 Feb 2025 20:59:46 +0100
Subject: [PATCH] upgpkg: tuned-git 2.25.0.r2.ga96d7d9-1: Fix installation
 paths

upstream release
Add SBINDIR to set correct installation path
Fix libexec scripts installation that were previously left out
---
 .SRCINFO | 2 +-
 PKGBUILD | 9 ++++-----
 2 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index cedbe23..d64ee8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = tuned-git
 	pkgdesc = Daemon that performs monitoring and adaptive configuration of devices in the system
-	pkgver = 2.24.1.r0.g90c24ee
+	pkgver = 2.25.0.r2.ga96d7d9
 	pkgrel = 1
 	url = https://github.com/redhat-performance/tuned
 	arch = any
diff --git a/PKGBUILD b/PKGBUILD
index a263354..fe3da1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
 _pkgbase=tuned
 pkgbase="${_pkgbase}-git"
 pkgname=("${_pkgbase}-git" "${_pkgbase}-ppd-git")
-pkgver=2.24.1.r0.g90c24ee
+pkgver=2.25.0.r2.ga96d7d9
 pkgrel=1
 pkgdesc='Daemon that performs monitoring and adaptive configuration of devices in the system'
 arch=('any')
@@ -26,10 +26,9 @@ pkgver() {
 
 prepare() {
 	cd "${_pkgbase}"
-	mv libexec lib
 
 	sed -i 's|/libexec/|/lib/|g' Makefile
-	sed -i 's|/sbin/|/bin/|g' Makefile tuned.service tuned-gui.py tuned-gui.desktop tuned/ppd/tuned-ppd.service
+	sed -i 's|/sbin/|/bin/|g' tuned.service tuned-gui.py tuned-gui.desktop tuned/ppd/tuned-ppd.service
 }
 
 package_tuned-git() {
@@ -53,7 +52,7 @@ package_tuned-git() {
 
 	cd "${_pkgbase}"
 
-	make DESTDIR="${pkgdir}" install
+	make DESTDIR="${pkgdir}" SBINDIR="/usr/bin" install
 	rm -rv "${pkgdir}"/{run,var}
 
 	python -m compileall -d /usr/lib "${pkgdir}/usr/lib"
@@ -69,5 +68,5 @@ package_tuned-ppd-git() {
 
 	cd "${_pkgbase}"
 
-	make DESTDIR="${pkgdir}" install-ppd
+	make DESTDIR="${pkgdir}" SBINDIR="/usr/bin" install-ppd
 }