Initial import

This commit is contained in:
Jonathan Liu 2018-12-11 11:30:43 +11:00
commit 332931541d
3 changed files with 64 additions and 0 deletions

16
.SRCINFO Normal file
View File

@ -0,0 +1,16 @@
pkgbase = wxedid
pkgdesc = wxWidgets-based EDID (Extended Display Identification Data) editor
pkgver = 0.0.16
pkgrel = 1
url = https://sourceforge.net/projects/wxedid/
arch = i686
arch = x86_64
license = GPL3
depends = wxgtk2
source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.16.tar.gz
source = configure.patch
md5sums = 0b1a6c49274e0fc3f2398648d99d6954
md5sums = 519658fdadcbe8c0b66c6d47c1c8715f
pkgname = wxedid

37
PKGBUILD Normal file
View File

@ -0,0 +1,37 @@
# Maintainer: Jonathan Liu <net147@gmail.com>
pkgname=wxedid
pkgver=0.0.16
pkgrel=1
pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
arch=('i686' 'x86_64')
url="https://sourceforge.net/projects/wxedid/"
license=('GPL3')
depends=('wxgtk2')
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
'configure.patch')
md5sums=('0b1a6c49274e0fc3f2398648d99d6954'
'519658fdadcbe8c0b66c6d47c1c8715f')
prepare() {
cd "$pkgname-$pkgver"
patch -Np1 -i "$srcdir/configure.patch"
}
build() {
cd "$pkgname-$pkgver"
autoreconf -f -i
./configure --prefix=/usr
make
}
check() {
cd "$pkgname-$pkgver"
make -k check
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
# vim:set ts=2 sw=2 et:

11
configure.patch Normal file
View File

@ -0,0 +1,11 @@
--- a/configure.ac 2018-12-01 23:43:13.000000000 +1100
+++ b/configure.ac 2018-12-11 10:50:59.989268036 +1100
@@ -24,8 +24,6 @@
AS_VAR_SET([ac_lang_cflags], [$CFLAGS])
dnl AC_ARG_SWITCH_DEBUG([DEFINE-DBG-VAR], [DBG-CFLAGS], [DBG-LDFLAGS], [RELEASE-CFLAGS], [RELEASE-LDLAGS])
-AC_BUILD_SWITCH([-g -Wall -Wextra -fno-exceptions], [],
- [-s -O2 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [])
AC_SUBST([ac_lang_cflags])