moved to AUR

This commit is contained in:
Christian Rebischke 2018-02-14 12:31:23 +01:00
parent 5a3ef0f5d1
commit 68ebb46082
WARNING! Although there is a key with this ID in the database it does not verify this commit! This commit is SUSPICIOUS.
GPG key ID: D21461E3DFE2060D
4 changed files with 56 additions and 18 deletions

View file

@ -1,19 +1,25 @@
pkgbase = systemtap
pkgdesc = SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system.
pkgver = 3.1
pkgrel = 3
pkgdesc = provides infrastructure to simplify the gathering of information about the running system.
pkgver = 3.2
pkgrel = 1
url = http://sourceware.org/systemtap/
install = systemtap.install
arch = i686
arch = x86_64
arch = i686
license = GPL
makedepends = python2-setuptools
makedepends = xmlto
depends = elfutils
depends = nss
depends = python2
optdepends = sqlite3
source = systemtap-3.1.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-3.1.tar.gz
sha512sums = 10019b9c2d66f3f8d6e6ce3d1f3dfe99c9e5bda9f220eb2aa885643235c270c2004528cded0e94370cc0fc0c62d8fbe96cafa7609c619a8ee498335ecd0aa41d
optdepends = sqlite3: for storing results in a database
source = systemtap-3.2.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-3.2.tar.gz
source = systemtap-3.2.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-3.2.tar.gz.asc
source = access_process_vm_h.patch
validpgpkeys = 5D38116FA4D3A7CC77E378D37E83610126DCC2E8
sha512sums = 6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94
sha512sums = SKIP
sha512sums = f33d81d2e4d0892cb248e89eb11b76d390f78ef7e50dca8d15e0a868c1a42fb0fc40ea69d6d967ebd65dd7d7a910bf8b2faf31378dc744ef1e13aeb423a2572b
pkgname = systemtap

View file

@ -1,20 +1,28 @@
# $Id: PKGBUILD 219416 2017-03-27 19:17:50Z shibumi $
# Maintainer : Christian Rebischke <Chris.Rebischke@archlinux.org>
# Contributor:dront78 <dront78@gmail.com>
pkgname=systemtap
pkgver=3.1
pkgrel=3
pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
pkgver=3.2
pkgrel=1
pkgdesc="provides infrastructure to simplify the gathering of information about the running system."
url="http://sourceware.org/systemtap/"
arch=('i686' 'x86_64')
arch=('x86_64' 'i686')
license=('GPL')
depends=('elfutils' 'nss' 'python2')
makedepends=('python2-setuptools')
optdepends=('sqlite3')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz")
sha512sums=('10019b9c2d66f3f8d6e6ce3d1f3dfe99c9e5bda9f220eb2aa885643235c270c2004528cded0e94370cc0fc0c62d8fbe96cafa7609c619a8ee498335ecd0aa41d')
makedepends=('python2-setuptools' 'xmlto')
optdepends=('sqlite3: for storing results in a database')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
'access_process_vm_h.patch')
sha512sums=('6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94'
'SKIP'
'f33d81d2e4d0892cb248e89eb11b76d390f78ef7e50dca8d15e0a868c1a42fb0fc40ea69d6d967ebd65dd7d7a910bf8b2faf31378dc744ef1e13aeb423a2572b')
install='systemtap.install'
validpgpkeys=('5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
prepare() {
cd "${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/access_process_vm_h.patch"
}
build() {
cd "${pkgname}-${pkgver}"
./configure \
@ -23,14 +31,17 @@ build() {
--libexecdir=/usr/lib/"${pkgname}" \
--libdir=/usr/lib/"${pkgname}" \
--mandir=/usr/share/man/ \
--localstatedir=/var/run/"${pkgname}" \
--localstatedir=/var \
--enable-pie \
--disable-docs
--disable-docs \
--enable-htmldocs
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
rmdir "${pkgdir}/var/run/stap-server/"
rmdir "${pkgdir}/var/run/"
}

10
access_process_vm_h.patch Normal file
View file

@ -0,0 +1,10 @@
--- ./runtime/linux/access_process_vm.h 2017-02-17 18:37:01.000000000 +0100
+++ /usr/share/systemtap/runtime/linux/access_process_vm.h 2017-08-09 11:47:50.332532411 +0200
@@ -4,6 +4,7 @@
* we copied and pasted it here. Fortunately, everything it calls is exported.
*/
#include <linux/pagemap.h>
+#include <linux/sched/mm.h>
#include <asm/cacheflush.h>
static int

11
stp_utrace_c.patch Normal file
View file

@ -0,0 +1,11 @@
--- ./runtime/stp_utrace.c 2017-02-17 18:37:01.000000000 +0100
+++ /usr/share/systemtap/runtime/stp_utrace.c 2017-08-09 11:59:21.542501780 +0200
@@ -1105,7 +1105,7 @@
*/
spin_lock_irq(&target->sighand->siglock);
if (likely(task_is_stopped(target)))
- __set_task_state(target, TASK_TRACED);
+ set_current_state(TASK_TRACED);
spin_unlock_irq(&target->sighand->siglock);
} else if (utrace->resume > UTRACE_REPORT) {
utrace->resume = UTRACE_REPORT;