Fix up meson & cargo arguments for spot-client
This commit is contained in:
parent
0ce3385263
commit
6cc2200153
3 changed files with 58 additions and 6 deletions
6
.SRCINFO
6
.SRCINFO
|
@ -1,7 +1,7 @@
|
||||||
pkgbase = spot-client
|
pkgbase = spot-client
|
||||||
pkgdesc = Gtk/Rust native Spotify client
|
pkgdesc = Gtk/Rust native Spotify client
|
||||||
pkgver = 0.1.10
|
pkgver = 0.1.10
|
||||||
pkgrel = 1
|
pkgrel = 2
|
||||||
url = https://github.com/xou816/spot
|
url = https://github.com/xou816/spot
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
arch = i686
|
arch = i686
|
||||||
|
@ -19,7 +19,9 @@ pkgbase = spot-client
|
||||||
depends = libpulse
|
depends = libpulse
|
||||||
depends = openssl
|
depends = openssl
|
||||||
optdepends = org.freedesktop.secrets
|
optdepends = org.freedesktop.secrets
|
||||||
source = spot-client-0.1.10-1.tar.gz::https://github.com/xou816/spot/archive/0.1.10.tar.gz
|
source = spot-client-0.1.10-2.tar.gz::https://github.com/xou816/spot/archive/0.1.10.tar.gz
|
||||||
|
source = meson-test-release.diff
|
||||||
sha256sums = 9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979
|
sha256sums = 9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979
|
||||||
|
sha256sums = 4366433646f05f74cb9cdc23079ad37655e06589cd28ecd3cd156223ff213a95
|
||||||
|
|
||||||
pkgname = spot-client
|
pkgname = spot-client
|
||||||
|
|
18
PKGBUILD
18
PKGBUILD
|
@ -2,7 +2,7 @@
|
||||||
_projectname='spot'
|
_projectname='spot'
|
||||||
pkgname="$_projectname-client"
|
pkgname="$_projectname-client"
|
||||||
pkgver='0.1.10'
|
pkgver='0.1.10'
|
||||||
pkgrel='1'
|
pkgrel='2'
|
||||||
pkgdesc='Gtk/Rust native Spotify client'
|
pkgdesc='Gtk/Rust native Spotify client'
|
||||||
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
||||||
url="https://github.com/xou816/$_projectname"
|
url="https://github.com/xou816/$_projectname"
|
||||||
|
@ -10,15 +10,25 @@ license=('MIT')
|
||||||
depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
|
depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
|
||||||
makedepends=('cargo' 'meson>=0.50.0')
|
makedepends=('cargo' 'meson>=0.50.0')
|
||||||
optdepends=('org.freedesktop.secrets')
|
optdepends=('org.freedesktop.secrets')
|
||||||
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
|
source=(
|
||||||
sha256sums=('9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979')
|
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
|
||||||
|
'meson-test-release.diff'
|
||||||
|
)
|
||||||
|
sha256sums=('9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979'
|
||||||
|
'4366433646f05f74cb9cdc23079ad37655e06589cd28ecd3cd156223ff213a95')
|
||||||
|
|
||||||
_sourcedirectory="$_projectname-$pkgver"
|
_sourcedirectory="$_projectname-$pkgver"
|
||||||
_builddirectory='build'
|
_builddirectory='build'
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "$srcdir/$_sourcedirectory/"
|
||||||
|
patch --forward -p1 < '../meson-test-release.diff'
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/"
|
cd "$srcdir/"
|
||||||
arch-meson "$_sourcedirectory" "$_builddirectory" -Doffline=false -Dbuildtype=release
|
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
|
||||||
|
-Db_lto='true' -Db_pie='true' -Doffline='false' -Dfeatures='warn-cache' "$_sourcedirectory" "$_builddirectory"
|
||||||
meson compile -C "$_builddirectory"
|
meson compile -C "$_builddirectory"
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
40
meson-test-release.diff
Normal file
40
meson-test-release.diff
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
diff --git a/build-aux/test.sh b/build-aux/test.sh
|
||||||
|
index f8ca912..f3b9e8f 100644
|
||||||
|
--- a/build-aux/test.sh
|
||||||
|
+++ b/build-aux/test.sh
|
||||||
|
@@ -2,10 +2,19 @@
|
||||||
|
|
||||||
|
export SRC="$1"
|
||||||
|
export CARGO_TARGET_DIR="$2"/target
|
||||||
|
-export OFFLINE="$3"
|
||||||
|
+export BUILDTYPE="$3"
|
||||||
|
+export OFFLINE="$4"
|
||||||
|
+
|
||||||
|
+echo $BUILDTYPE
|
||||||
|
+
|
||||||
|
+if [[ $BUILDTYPE = "release" ]]; then
|
||||||
|
+ PROFILE_ARG="--release"
|
||||||
|
+else
|
||||||
|
+ PROFILE_ARG="--verbose"
|
||||||
|
+fi
|
||||||
|
|
||||||
|
if [[ $OFFLINE = "true" ]]; then
|
||||||
|
export CARGO_HOME="$SRC"/cargo
|
||||||
|
fi
|
||||||
|
|
||||||
|
-cargo test --manifest-path "$SRC"/Cargo.toml
|
||||||
|
\ No newline at end of file
|
||||||
|
+cargo test --manifest-path "$SRC"/Cargo.toml "$PROFILE_ARG"
|
||||||
|
\ No newline at end of file
|
||||||
|
diff --git a/src/meson.build b/src/meson.build
|
||||||
|
index 93d7387..909e9d6 100644
|
||||||
|
--- a/src/meson.build
|
||||||
|
+++ b/src/meson.build
|
||||||
|
@@ -140,6 +140,7 @@ test('Unit tests',
|
||||||
|
args: [
|
||||||
|
meson.source_root(),
|
||||||
|
meson.build_root(),
|
||||||
|
+ get_option('buildtype'),
|
||||||
|
get_option('offline') ? 'true' : 'false'
|
||||||
|
]
|
||||||
|
)
|
Loading…
Reference in a new issue