Patch ffmpeg 5.0 compatibility
Contributed by AUR user @gruenfron
This commit is contained in:
parent
c942c5b8a8
commit
77f2b6a0c3
3 changed files with 62 additions and 4 deletions
4
.SRCINFO
4
.SRCINFO
|
@ -1,7 +1,7 @@
|
||||||
pkgbase = bino
|
pkgbase = bino
|
||||||
pkgdesc = 3D video player with multi-display support
|
pkgdesc = 3D video player with multi-display support
|
||||||
pkgver = 1.6.8
|
pkgver = 1.6.8
|
||||||
pkgrel = 1
|
pkgrel = 2
|
||||||
url = https://bino3d.org/
|
url = https://bino3d.org/
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
license = GPL3
|
license = GPL3
|
||||||
|
@ -14,8 +14,10 @@ pkgbase = bino
|
||||||
optdepends = lirc: infrared remote control
|
optdepends = lirc: infrared remote control
|
||||||
source = https://bino3d.org/releases/bino-1.6.8.tar.xz
|
source = https://bino3d.org/releases/bino-1.6.8.tar.xz
|
||||||
source = https://bino3d.org/releases/bino-1.6.8.tar.xz.sig
|
source = https://bino3d.org/releases/bino-1.6.8.tar.xz.sig
|
||||||
|
source = ffmpeg4.4.patch
|
||||||
validpgpkeys = 2F61B4828BBA779AECB3F32703A2A4AB1E32FD34
|
validpgpkeys = 2F61B4828BBA779AECB3F32703A2A4AB1E32FD34
|
||||||
sha512sums = d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc
|
sha512sums = d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc
|
||||||
sha512sums = SKIP
|
sha512sums = SKIP
|
||||||
|
sha512sums = d4768179c13079fb93a5e8c36a4228245ff04e1049a8186f942fe2d3e20a8d34b9064d140a1aaf4c5499405bb34e8924b3fffd0fabf2e1652b5a1c3cbb1d343a
|
||||||
|
|
||||||
pkgname = bino
|
pkgname = bino
|
||||||
|
|
14
PKGBUILD
14
PKGBUILD
|
@ -1,21 +1,29 @@
|
||||||
# Maintainer: Manuel Hüsers <aur@huesers.de>
|
# Maintainer: Manuel Hüsers <aur@huesers.de>
|
||||||
|
# Contributor: gruenfron <https://aur.archlinux.org/account/gruenfron>
|
||||||
# Contributor: Jose Riha <jose1711 gmail com>
|
# Contributor: Jose Riha <jose1711 gmail com>
|
||||||
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
|
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
|
||||||
|
|
||||||
pkgname=bino
|
pkgname=bino
|
||||||
pkgver=1.6.8
|
pkgver=1.6.8
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc='3D video player with multi-display support'
|
pkgdesc='3D video player with multi-display support'
|
||||||
arch=('x86_64')
|
arch=('x86_64')
|
||||||
url='https://bino3d.org/'
|
url='https://bino3d.org/'
|
||||||
license=('GPL3')
|
license=('GPL3')
|
||||||
depends=('ffmpeg' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
|
depends=('ffmpeg' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
|
||||||
optdepends=('lirc: infrared remote control')
|
optdepends=('lirc: infrared remote control')
|
||||||
source=(https://bino3d.org/releases/bino-${pkgver}.tar.xz{,.sig})
|
source=(https://bino3d.org/releases/bino-${pkgver}.tar.xz{,.sig}
|
||||||
|
ffmpeg4.4.patch)
|
||||||
sha512sums=('d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc'
|
sha512sums=('d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc'
|
||||||
'SKIP')
|
'SKIP'
|
||||||
|
'd4768179c13079fb93a5e8c36a4228245ff04e1049a8186f942fe2d3e20a8d34b9064d140a1aaf4c5499405bb34e8924b3fffd0fabf2e1652b5a1c3cbb1d343a')
|
||||||
validpgpkeys=('2F61B4828BBA779AECB3F32703A2A4AB1E32FD34')
|
validpgpkeys=('2F61B4828BBA779AECB3F32703A2A4AB1E32FD34')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
|
patch -Np1 -i '../ffmpeg4.4.patch'
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
./configure \
|
./configure \
|
||||||
|
|
48
ffmpeg4.4.patch
Normal file
48
ffmpeg4.4.patch
Normal file
|
@ -0,0 +1,48 @@
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -143,25 +143,6 @@ if test -z "$PKG_CONFIG"; then
|
||||||
|
AC_MSG_WARN([please install pkg-config; Debian package: pkg-config])
|
||||||
|
fi
|
||||||
|
|
||||||
|
-dnl FFmpeg
|
||||||
|
-PKG_CHECK_MODULES([libavformat], [libavformat >= 52.110.0 libavcodec libavutil], [HAVE_LIBAVFORMAT=1], [HAVE_LIBAVFORMAT=0])
|
||||||
|
-if test "$HAVE_LIBAVFORMAT" != "1"; then
|
||||||
|
- AC_MSG_WARN([required library libavformat >= 52.110.0 not found:])
|
||||||
|
- AC_MSG_WARN([$libavformat_PKG_ERRORS])
|
||||||
|
- AC_MSG_WARN([libavformat >= 52.110.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||||
|
-fi
|
||||||
|
-PKG_CHECK_MODULES([libavdevice], [libavdevice >= 52.5.0], [HAVE_LIBAVDEVICE=1], [HAVE_LIBAVDEVICE=0])
|
||||||
|
-if test "$HAVE_LIBAVDEVICE" != "1"; then
|
||||||
|
- AC_MSG_WARN([required library libavdevice >= 52.5.0 not found:])
|
||||||
|
- AC_MSG_WARN([$libavdevice_PKG_ERRORS])
|
||||||
|
- AC_MSG_WARN([libavdevice >= 52.5.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||||
|
-fi
|
||||||
|
-PKG_CHECK_MODULES([libswscale], [libswscale >= 0.14.1 libavutil], [HAVE_LIBSWSCALE=1], [HAVE_LIBSWSCALE=0])
|
||||||
|
-if test "$HAVE_LIBSWSCALE" != "1"; then
|
||||||
|
- AC_MSG_WARN([required library libswscale >= 0.14.1 not found:])
|
||||||
|
- AC_MSG_WARN([$libswscale_PKG_ERRORS])
|
||||||
|
- AC_MSG_WARN([libswscale >= 0.14.1 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||||
|
-fi
|
||||||
|
AC_CHECK_FUNCS([sysconf])
|
||||||
|
|
||||||
|
dnl libass
|
||||||
|
@@ -400,11 +381,16 @@ UPDATE_DESKTOP_DATABASE=""
|
||||||
|
AC_ARG_VAR([UPDATE_DESKTOP_DATABASE], [update-desktop-database command])
|
||||||
|
AC_CHECK_PROGS([UPDATE_DESKTOP_DATABASE], [update-desktop-database])
|
||||||
|
|
||||||
|
+dnl ffmpeg4.4 libs
|
||||||
|
+LIBS+=" /usr/lib/libswscale.so.5"
|
||||||
|
+LIBS+=" /usr/lib/libavutil.so.56"
|
||||||
|
+LIBS+=" /usr/lib/libavformat.so.58"
|
||||||
|
+LIBS+=" /usr/lib/libavdevice.so.58"
|
||||||
|
+LIBS+=" /usr/lib/libavcodec.so.58"
|
||||||
|
+CPPFLAGS+=" -I/usr/include/ffmpeg4.4"
|
||||||
|
+
|
||||||
|
dnl Check if all libraries were found
|
||||||
|
if test "$am_cv_func_iconv" != "yes" \
|
||||||
|
- -o "$HAVE_LIBAVFORMAT" != "1" \
|
||||||
|
- -o "$HAVE_LIBAVDEVICE" != "1" \
|
||||||
|
- -o "$HAVE_LIBSWSCALE" != "1" \
|
||||||
|
-o "$HAVE_LIBASS" != "1" \
|
||||||
|
-o "$HAVE_LIBOPENAL" != "1" \
|
||||||
|
-o "$HAVE_LIBQTOPENGL" != "1" \
|
Loading…
Reference in a new issue