Initial commit with version 5.0.1
This commit is contained in:
commit
85931efab9
3 changed files with 82 additions and 0 deletions
37
.SRCINFO
Normal file
37
.SRCINFO
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
pkgbase = clonezilla-unstable
|
||||||
|
pkgdesc = ncurses partition and disk imaging/cloning program
|
||||||
|
pkgver = 5.0.1
|
||||||
|
pkgrel = 1
|
||||||
|
url = https://clonezilla.org
|
||||||
|
arch = any
|
||||||
|
license = GPL2
|
||||||
|
depends = drbl
|
||||||
|
depends = partclone
|
||||||
|
depends = ntfs-3g
|
||||||
|
depends = partimage
|
||||||
|
depends = pigz
|
||||||
|
depends = sshfs
|
||||||
|
depends = parted
|
||||||
|
depends = gptfdisk
|
||||||
|
depends = dosfstools
|
||||||
|
depends = gzip
|
||||||
|
depends = bzip2
|
||||||
|
depends = pbzip2
|
||||||
|
depends = lbzip2
|
||||||
|
depends = lrzip
|
||||||
|
depends = xz
|
||||||
|
depends = pixz
|
||||||
|
depends = lzop
|
||||||
|
depends = ecryptfs-utils
|
||||||
|
depends = screen
|
||||||
|
depends = perl
|
||||||
|
depends = cifs-utils
|
||||||
|
provides = clonezilla
|
||||||
|
conflicts = clonezilla
|
||||||
|
backup = etc/drbl/drbl-ocs.conf
|
||||||
|
source = https://free.nchc.org.tw/drbl-core/src/unstable/clonezilla-5.0.1.tar.xz
|
||||||
|
source = usrbin.patch
|
||||||
|
sha256sums = 08ff61f8e5c5a3328cf00cb67636fcc2668700a4a1202d44c8d6f7222eb6c578
|
||||||
|
sha256sums = 9340f18b27a1b3b41c4935c5831f6503e4cadf333f03433769906da40a6e38e6
|
||||||
|
|
||||||
|
pkgname = clonezilla-unstable
|
32
PKGBUILD
Normal file
32
PKGBUILD
Normal file
|
@ -0,0 +1,32 @@
|
||||||
|
# Maintainer: Manuel Hüsers <aur@huesers.de>
|
||||||
|
|
||||||
|
pkgname=clonezilla-unstable
|
||||||
|
_pkgname=clonezilla
|
||||||
|
pkgver=5.0.1
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="ncurses partition and disk imaging/cloning program"
|
||||||
|
arch=('any')
|
||||||
|
url="https://clonezilla.org"
|
||||||
|
license=('GPL2')
|
||||||
|
depends=('drbl' 'partclone' 'ntfs-3g' 'partimage' 'pigz' 'sshfs' 'parted'
|
||||||
|
'gptfdisk' 'dosfstools' 'gzip' 'bzip2' 'pbzip2' 'lbzip2' 'lrzip'
|
||||||
|
'xz' 'pixz' 'lzop' 'ecryptfs-utils' 'screen' 'perl' 'cifs-utils')
|
||||||
|
backup=('etc/drbl/drbl-ocs.conf')
|
||||||
|
conflicts=("${_pkgname}")
|
||||||
|
provides=("${_pkgname}")
|
||||||
|
source=("https://free.nchc.org.tw/drbl-core/src/unstable/${_pkgname}-${pkgver}.tar.xz"
|
||||||
|
'usrbin.patch')
|
||||||
|
sha256sums=('08ff61f8e5c5a3328cf00cb67636fcc2668700a4a1202d44c8d6f7222eb6c578'
|
||||||
|
'9340f18b27a1b3b41c4935c5831f6503e4cadf333f03433769906da40a6e38e6')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${_pkgname}-${pkgver}"
|
||||||
|
|
||||||
|
patch -Np0 -i "${srcdir}/usrbin.patch"
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd "${_pkgname}-${pkgver}"
|
||||||
|
|
||||||
|
make DESTDIR="${pkgdir}" install
|
||||||
|
}
|
13
usrbin.patch
Normal file
13
usrbin.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
--- Makefile.orig 2013-05-30 17:42:49.851418658 +0100
|
||||||
|
+++ Makefile 2013-05-30 17:44:41.157482402 +0100
|
||||||
|
@@ -18,8 +18,8 @@
|
||||||
|
|
||||||
|
install:
|
||||||
|
# install exec files
|
||||||
|
- install -d ${DESTDIR}/usr/
|
||||||
|
- cp -a sbin bin ${DESTDIR}/usr/
|
||||||
|
+ install -d ${DESTDIR}/usr/bin
|
||||||
|
+ cp -a sbin/* bin/* ${DESTDIR}/usr/bin/
|
||||||
|
|
||||||
|
# install setup dir
|
||||||
|
install -d $(DESTDIR)/$(SHAREDIR)/
|
Loading…
Reference in a new issue