Update to 0.0.18-1
This commit is contained in:
parent
60f19ba8ca
commit
90f981a615
3 changed files with 12 additions and 11 deletions
8
.SRCINFO
8
.SRCINFO
|
@ -1,16 +1,16 @@
|
||||||
pkgbase = wxedid
|
pkgbase = wxedid
|
||||||
pkgdesc = wxWidgets-based EDID (Extended Display Identification Data) editor
|
pkgdesc = wxWidgets-based EDID (Extended Display Identification Data) editor
|
||||||
pkgver = 0.0.17
|
pkgver = 0.0.18
|
||||||
pkgrel = 1
|
pkgrel = 1
|
||||||
url = https://sourceforge.net/projects/wxedid/
|
url = https://sourceforge.net/projects/wxedid/
|
||||||
arch = i686
|
arch = i686
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
license = GPL3
|
license = GPL3
|
||||||
depends = wxgtk2
|
depends = wxgtk2
|
||||||
source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.17.tar.gz
|
source = https://downloads.sourceforge.net/wxedid/wxedid-0.0.18.tar.gz
|
||||||
source = configure.patch
|
source = configure.patch
|
||||||
md5sums = eb09f18621954eece112a8266d4f0f74
|
md5sums = 4098b6355d6a0ed76d06c33bb9499b27
|
||||||
md5sums = 519658fdadcbe8c0b66c6d47c1c8715f
|
md5sums = 1443b5b6e81b32df7c4a5c036603c52f
|
||||||
|
|
||||||
pkgname = wxedid
|
pkgname = wxedid
|
||||||
|
|
||||||
|
|
9
PKGBUILD
9
PKGBUILD
|
@ -1,6 +1,6 @@
|
||||||
# Maintainer: Jonathan Liu <net147@gmail.com>
|
# Maintainer: Jonathan Liu <net147@gmail.com>
|
||||||
pkgname=wxedid
|
pkgname=wxedid
|
||||||
pkgver=0.0.17
|
pkgver=0.0.18
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
|
pkgdesc="wxWidgets-based EDID (Extended Display Identification Data) editor"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
|
@ -9,14 +9,15 @@ license=('GPL3')
|
||||||
depends=('wxgtk2')
|
depends=('wxgtk2')
|
||||||
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
|
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
|
||||||
'configure.patch')
|
'configure.patch')
|
||||||
md5sums=('eb09f18621954eece112a8266d4f0f74'
|
md5sums=('4098b6355d6a0ed76d06c33bb9499b27'
|
||||||
'519658fdadcbe8c0b66c6d47c1c8715f')
|
'1443b5b6e81b32df7c4a5c036603c52f')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd "$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
patch -Np1 -i "$srcdir/configure.patch"
|
patch -Np1 -i "$srcdir/configure.patch"
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
autoreconf -f -i
|
autoreconf -f -i
|
||||||
|
@ -31,7 +32,7 @@ check() {
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "$pkgname-$pkgver"
|
cd "$pkgname-$pkgver"
|
||||||
make DESTDIR="$pkgdir/" install
|
make DESTDIR="$pkgdir" install
|
||||||
}
|
}
|
||||||
|
|
||||||
# vim:set ts=2 sw=2 et:
|
# vim:set ts=2 sw=2 et:
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
--- a/configure.ac 2018-12-01 23:43:13.000000000 +1100
|
--- a/configure.ac
|
||||||
+++ b/configure.ac 2018-12-11 10:50:59.989268036 +1100
|
+++ b/configure.ac
|
||||||
@@ -24,8 +24,6 @@
|
@@ -24,8 +24,6 @@
|
||||||
AS_VAR_SET([ac_lang_cflags], [$CFLAGS])
|
AS_VAR_SET([ac_lang_cflags], [$CFLAGS])
|
||||||
|
|
||||||
dnl AC_ARG_SWITCH_DEBUG([DEFINE-DBG-VAR], [DBG-CFLAGS], [DBG-LDFLAGS], [RELEASE-CFLAGS], [RELEASE-LDLAGS])
|
dnl AC_ARG_SWITCH_DEBUG([DEFINE-DBG-VAR], [DBG-CFLAGS], [DBG-LDFLAGS], [RELEASE-CFLAGS], [RELEASE-LDLAGS])
|
||||||
-AC_BUILD_SWITCH([-g -Wall -Wextra -fno-exceptions], [],
|
-AC_BUILD_SWITCH([-g -Wall -Wextra -fno-exceptions], [],
|
||||||
- [-s -O2 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [])
|
- [-O1 -finline-functions-called-once -fno-exceptions -Wall -Wfatal-errors], [-s])
|
||||||
|
|
||||||
AC_SUBST([ac_lang_cflags])
|
AC_SUBST([ac_lang_cflags])
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue