Add 'bino/' from commit 'cb7fe24648232137bdb358cf58c9e154fca47a26'
git-subtree-dir: bino git-subtree-mainline:9f7af08ef5
git-subtree-split:cb7fe24648
This commit is contained in:
commit
af8a24ac62
3 changed files with 110 additions and 0 deletions
23
bino/.SRCINFO
Normal file
23
bino/.SRCINFO
Normal file
|
@ -0,0 +1,23 @@
|
|||
pkgbase = bino
|
||||
pkgdesc = 3D video player with multi-display support
|
||||
pkgver = 1.6.8
|
||||
pkgrel = 4
|
||||
url = https://bino3d.org/
|
||||
arch = x86_64
|
||||
license = GPL3
|
||||
depends = ffmpeg4.4
|
||||
depends = freealut
|
||||
depends = freeglut
|
||||
depends = glewmx
|
||||
depends = libass
|
||||
depends = qt5-base
|
||||
optdepends = lirc: infrared remote control
|
||||
source = https://bino3d.org/releases/bino-1.6.8.tar.xz
|
||||
source = https://bino3d.org/releases/bino-1.6.8.tar.xz.sig
|
||||
source = ffmpeg4.4.patch
|
||||
validpgpkeys = 2F61B4828BBA779AECB3F32703A2A4AB1E32FD34
|
||||
sha512sums = d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc
|
||||
sha512sums = SKIP
|
||||
sha512sums = f7bf716a6ae12a4542ecaddeaee1078a6c26d9d765db7cc11a1d7b1ae19b295703f5b05e71564f1aad216485b904d81f2670c122e88ab79c7556f5614c0d1639
|
||||
|
||||
pkgname = bino
|
39
bino/PKGBUILD
Normal file
39
bino/PKGBUILD
Normal file
|
@ -0,0 +1,39 @@
|
|||
# Maintainer: Manuel Hüsers <aur@huesers.de>
|
||||
# Contributor: gruenfron <https://aur.archlinux.org/account/gruenfron>
|
||||
# Contributor: Jose Riha <jose1711 gmail com>
|
||||
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
|
||||
|
||||
pkgname=bino
|
||||
pkgver=1.6.8
|
||||
pkgrel=4
|
||||
pkgdesc='3D video player with multi-display support'
|
||||
arch=('x86_64')
|
||||
url='https://bino3d.org/'
|
||||
license=('GPL3')
|
||||
depends=('ffmpeg4.4' 'freealut' 'freeglut' 'glewmx' 'libass' 'qt5-base')
|
||||
optdepends=('lirc: infrared remote control')
|
||||
source=(https://bino3d.org/releases/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
ffmpeg4.4.patch)
|
||||
sha512sums=('d8cf5be356add4ed3fb36673038b5ffd92d0dc840798cc616fa4b11fec221c7f114347dfc7cdb7a3a24c5599b56301cddc99f84d3862d8e874612960281319cc'
|
||||
'SKIP'
|
||||
'f7bf716a6ae12a4542ecaddeaee1078a6c26d9d765db7cc11a1d7b1ae19b295703f5b05e71564f1aad216485b904d81f2670c122e88ab79c7556f5614c0d1639')
|
||||
validpgpkeys=('2F61B4828BBA779AECB3F32703A2A4AB1E32FD34')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
patch -Np1 -i '../ffmpeg4.4.patch'
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--with-qt-version=5 \
|
||||
#--with-xnvctrl # Enable NVIDIA Quadro SDI output
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make DESTDIR="${pkgdir}" install
|
||||
}
|
48
bino/ffmpeg4.4.patch
Normal file
48
bino/ffmpeg4.4.patch
Normal file
|
@ -0,0 +1,48 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -143,25 +143,6 @@ if test -z "$PKG_CONFIG"; then
|
||||
AC_MSG_WARN([please install pkg-config; Debian package: pkg-config])
|
||||
fi
|
||||
|
||||
-dnl FFmpeg
|
||||
-PKG_CHECK_MODULES([libavformat], [libavformat >= 52.110.0 libavcodec libavutil], [HAVE_LIBAVFORMAT=1], [HAVE_LIBAVFORMAT=0])
|
||||
-if test "$HAVE_LIBAVFORMAT" != "1"; then
|
||||
- AC_MSG_WARN([required library libavformat >= 52.110.0 not found:])
|
||||
- AC_MSG_WARN([$libavformat_PKG_ERRORS])
|
||||
- AC_MSG_WARN([libavformat >= 52.110.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||
-fi
|
||||
-PKG_CHECK_MODULES([libavdevice], [libavdevice >= 52.5.0], [HAVE_LIBAVDEVICE=1], [HAVE_LIBAVDEVICE=0])
|
||||
-if test "$HAVE_LIBAVDEVICE" != "1"; then
|
||||
- AC_MSG_WARN([required library libavdevice >= 52.5.0 not found:])
|
||||
- AC_MSG_WARN([$libavdevice_PKG_ERRORS])
|
||||
- AC_MSG_WARN([libavdevice >= 52.5.0 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||
-fi
|
||||
-PKG_CHECK_MODULES([libswscale], [libswscale >= 0.14.1 libavutil], [HAVE_LIBSWSCALE=1], [HAVE_LIBSWSCALE=0])
|
||||
-if test "$HAVE_LIBSWSCALE" != "1"; then
|
||||
- AC_MSG_WARN([required library libswscale >= 0.14.1 not found:])
|
||||
- AC_MSG_WARN([$libswscale_PKG_ERRORS])
|
||||
- AC_MSG_WARN([libswscale >= 0.14.1 is provided by libav >= 0.7 or FFmpeg >= 0.7])
|
||||
-fi
|
||||
AC_CHECK_FUNCS([sysconf])
|
||||
|
||||
dnl libass
|
||||
@@ -400,11 +381,16 @@ UPDATE_DESKTOP_DATABASE=""
|
||||
AC_ARG_VAR([UPDATE_DESKTOP_DATABASE], [update-desktop-database command])
|
||||
AC_CHECK_PROGS([UPDATE_DESKTOP_DATABASE], [update-desktop-database])
|
||||
|
||||
+dnl ffmpeg4.4 libs
|
||||
+LIBS="$LIBS /usr/lib/libswscale.so.5"
|
||||
+LIBS="$LIBS /usr/lib/libavutil.so.56"
|
||||
+LIBS="$LIBS /usr/lib/libavformat.so.58"
|
||||
+LIBS="$LIBS /usr/lib/libavdevice.so.58"
|
||||
+LIBS="$LIBS /usr/lib/libavcodec.so.58"
|
||||
+CPPFLAGS="$CPPFLAGS -I/usr/include/ffmpeg4.4"
|
||||
+
|
||||
dnl Check if all libraries were found
|
||||
if test "$am_cv_func_iconv" != "yes" \
|
||||
- -o "$HAVE_LIBAVFORMAT" != "1" \
|
||||
- -o "$HAVE_LIBAVDEVICE" != "1" \
|
||||
- -o "$HAVE_LIBSWSCALE" != "1" \
|
||||
-o "$HAVE_LIBASS" != "1" \
|
||||
-o "$HAVE_LIBOPENAL" != "1" \
|
||||
-o "$HAVE_LIBQTOPENGL" != "1" \
|
Loading…
Reference in a new issue