Fix failing Clippy tests for spot-client
This commit is contained in:
parent
ddfec238c3
commit
f37597e673
3 changed files with 28 additions and 5 deletions
6
.SRCINFO
6
.SRCINFO
|
@ -1,7 +1,7 @@
|
||||||
pkgbase = spot-client
|
pkgbase = spot-client
|
||||||
pkgdesc = Gtk/Rust native Spotify client
|
pkgdesc = Gtk/Rust native Spotify client
|
||||||
pkgver = 0.2.2
|
pkgver = 0.2.2
|
||||||
pkgrel = 1
|
pkgrel = 2
|
||||||
url = https://github.com/xou816/spot
|
url = https://github.com/xou816/spot
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
arch = i686
|
arch = i686
|
||||||
|
@ -24,7 +24,9 @@ pkgbase = spot-client
|
||||||
depends = openssl
|
depends = openssl
|
||||||
depends = pango
|
depends = pango
|
||||||
optdepends = org.freedesktop.secrets
|
optdepends = org.freedesktop.secrets
|
||||||
source = spot-client-0.2.2-1.tar.gz::https://github.com/xou816/spot/archive/0.2.2.tar.gz
|
source = spot-client-0.2.2-2.tar.gz::https://github.com/xou816/spot/archive/0.2.2.tar.gz
|
||||||
|
source = clippy.diff
|
||||||
sha512sums = 997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a
|
sha512sums = 997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a
|
||||||
|
sha512sums = 8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599
|
||||||
|
|
||||||
pkgname = spot-client
|
pkgname = spot-client
|
||||||
|
|
17
PKGBUILD
17
PKGBUILD
|
@ -3,7 +3,7 @@
|
||||||
_projectname='spot'
|
_projectname='spot'
|
||||||
pkgname="$_projectname-client"
|
pkgname="$_projectname-client"
|
||||||
pkgver='0.2.2'
|
pkgver='0.2.2'
|
||||||
pkgrel='1'
|
pkgrel='2'
|
||||||
pkgdesc='Gtk/Rust native Spotify client'
|
pkgdesc='Gtk/Rust native Spotify client'
|
||||||
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
||||||
url="https://github.com/xou816/$_projectname"
|
url="https://github.com/xou816/$_projectname"
|
||||||
|
@ -12,13 +12,24 @@ depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libp
|
||||||
optdepends=('org.freedesktop.secrets')
|
optdepends=('org.freedesktop.secrets')
|
||||||
makedepends=('cargo' 'meson>=0.50.0')
|
makedepends=('cargo' 'meson>=0.50.0')
|
||||||
checkdepends=('appstream-glib')
|
checkdepends=('appstream-glib')
|
||||||
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
|
source=(
|
||||||
sha512sums=('997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a')
|
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
|
||||||
|
'clippy.diff'
|
||||||
|
)
|
||||||
|
sha512sums=('997db5a651deb3290048a7283ee9f3b49387c51d6128a03ed3cf35b03df4db206d2502923df7ab45a0ef9fc45522c452edc74d4f16ccced8ca264a00e151887a'
|
||||||
|
'8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599')
|
||||||
validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
|
validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
|
||||||
|
|
||||||
_sourcedirectory="$_projectname-$pkgver"
|
_sourcedirectory="$_projectname-$pkgver"
|
||||||
_builddirectory='build'
|
_builddirectory='build'
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "$srcdir/$_sourcedirectory/"
|
||||||
|
|
||||||
|
# Until they're fixed upstream, ignore some newly thrown errors from clippy 1.57
|
||||||
|
patch --forward -p1 < "$srcdir/clippy.diff"
|
||||||
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/"
|
cd "$srcdir/"
|
||||||
# We're not using arch-meson, because upstream recommends using --buildtype 'release'
|
# We're not using arch-meson, because upstream recommends using --buildtype 'release'
|
||||||
|
|
10
clippy.diff
Normal file
10
clippy.diff
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
diff --git a/build-aux/clippy.sh b/build-aux/clippy.sh
|
||||||
|
index f60004b..22bdf6a 100644
|
||||||
|
--- a/build-aux/clippy.sh
|
||||||
|
+++ b/build-aux/clippy.sh
|
||||||
|
@@ -8,4 +8,4 @@ if [[ $OFFLINE = "true" ]]; then
|
||||||
|
export CARGO_HOME="$SRC"/cargo
|
||||||
|
fi
|
||||||
|
|
||||||
|
-cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default
|
||||||
|
+cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default -A dead-code -A clippy::large-enum-variant -A clippy::redundant-closure -A clippy::derivable-impls
|
Loading…
Reference in a new issue