Disable clippy tests for spot-client
This commit is contained in:
parent
eab9b3c628
commit
f8f9518535
3 changed files with 34 additions and 2 deletions
2
.SRCINFO
2
.SRCINFO
|
@ -25,6 +25,8 @@ pkgbase = spot-client
|
|||
depends = pango
|
||||
optdepends = org.freedesktop.secrets
|
||||
source = spot-client-0.3.1-1.tar.gz::https://github.com/xou816/spot/archive/0.3.1.tar.gz
|
||||
source = disable-clippy.patch
|
||||
sha512sums = b0127dbe2a1430dcc288c9ef6bd61f0afa92e4ca6316d4e84c7e6bf7051cffc90a8778312e04991f91a2090728a7ce3e288249d1c8562106f7851dc701e97873
|
||||
sha512sums = 1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1
|
||||
|
||||
pkgname = spot-client
|
||||
|
|
15
PKGBUILD
15
PKGBUILD
|
@ -12,13 +12,24 @@ depends=('alsa-lib' 'cairo' 'glib2' 'glibc' 'graphene' 'gtk4' 'libadwaita' 'libp
|
|||
optdepends=('org.freedesktop.secrets')
|
||||
makedepends=('cargo' 'meson>=0.50.0')
|
||||
checkdepends=('appstream-glib')
|
||||
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
|
||||
sha512sums=('b0127dbe2a1430dcc288c9ef6bd61f0afa92e4ca6316d4e84c7e6bf7051cffc90a8778312e04991f91a2090728a7ce3e288249d1c8562106f7851dc701e97873')
|
||||
source=(
|
||||
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
|
||||
'disable-clippy.patch'
|
||||
)
|
||||
sha512sums=('b0127dbe2a1430dcc288c9ef6bd61f0afa92e4ca6316d4e84c7e6bf7051cffc90a8778312e04991f91a2090728a7ce3e288249d1c8562106f7851dc701e97873'
|
||||
'1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1')
|
||||
validpgpkeys=() # waiting for https://github.com/xou816/spot/issues/283
|
||||
|
||||
_sourcedirectory="$_projectname-$pkgver"
|
||||
_builddirectory='build'
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$_sourcedirectory/"
|
||||
|
||||
# Disable clippy tests, as they don't realy make sense for user builds (https://gitlab.com/dpeukert/pkgbuilds/-/issues/37)
|
||||
patch --forward -p1 < '../disable-clippy.patch'
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/"
|
||||
# We're not using arch-meson, because upstream recommends using --buildtype 'release'
|
||||
|
|
19
disable-clippy.patch
Normal file
19
disable-clippy.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 755d870..fac1b77 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -208,14 +208,3 @@ test('Unit tests',
|
||||
],
|
||||
timeout: 180
|
||||
)
|
||||
-
|
||||
-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
|
||||
-test('Clippy',
|
||||
- cargo_clippy,
|
||||
- args: [
|
||||
- meson.source_root(),
|
||||
- meson.build_root(),
|
||||
- get_option('offline') ? 'true' : 'false'
|
||||
- ],
|
||||
- timeout: 180
|
||||
-)
|
Loading…
Reference in a new issue