arch-packages/meson-test-release.diff
2021-03-14 17:40:24 +01:00

41 lines
943 B
Diff

diff --git a/build-aux/test.sh b/build-aux/test.sh
index f8ca912..f3b9e8f 100644
--- a/build-aux/test.sh
+++ b/build-aux/test.sh
@@ -2,10 +2,19 @@
export SRC="$1"
export CARGO_TARGET_DIR="$2"/target
-export OFFLINE="$3"
+export BUILDTYPE="$3"
+export OFFLINE="$4"
+
+echo $BUILDTYPE
+
+if [[ $BUILDTYPE = "release" ]]; then
+ PROFILE_ARG="--release"
+else
+ PROFILE_ARG="--verbose"
+fi
if [[ $OFFLINE = "true" ]]; then
export CARGO_HOME="$SRC"/cargo
fi
-cargo test --manifest-path "$SRC"/Cargo.toml
\ No newline at end of file
+cargo test --manifest-path "$SRC"/Cargo.toml "$PROFILE_ARG"
\ No newline at end of file
diff --git a/src/meson.build b/src/meson.build
index 93d7387..909e9d6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -140,6 +140,7 @@ test('Unit tests',
args: [
meson.source_root(),
meson.build_root(),
+ get_option('buildtype'),
get_option('offline') ? 'true' : 'false'
]
)