Update spot-client to 0.1.11
This commit is contained in:
parent
6bb034a528
commit
71cec33e7d
3 changed files with 8 additions and 59 deletions
10
.SRCINFO
10
.SRCINFO
|
@ -1,7 +1,7 @@
|
|||
pkgbase = spot-client
|
||||
pkgdesc = Gtk/Rust native Spotify client
|
||||
pkgver = 0.1.10
|
||||
pkgrel = 4
|
||||
pkgver = 0.1.11
|
||||
pkgrel = 1
|
||||
url = https://github.com/xou816/spot
|
||||
arch = x86_64
|
||||
arch = i686
|
||||
|
@ -20,9 +20,7 @@ pkgbase = spot-client
|
|||
depends = libpulse
|
||||
depends = openssl
|
||||
optdepends = org.freedesktop.secrets
|
||||
source = spot-client-0.1.10-4.tar.gz::https://github.com/xou816/spot/archive/0.1.10.tar.gz
|
||||
source = spot-client-0.1.10-4-meson-test-release.diff::https://github.com/xou816/spot/commit/2dc722595e6bf716e46b779db6c8d3e239052ff2.diff
|
||||
sha256sums = 9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979
|
||||
sha256sums = 4366433646f05f74cb9cdc23079ad37655e06589cd28ecd3cd156223ff213a95
|
||||
source = spot-client-0.1.11-1.tar.gz::https://github.com/xou816/spot/archive/0.1.11.tar.gz
|
||||
sha256sums = 7f35be66edc2391ca80b9b870239b136d5c67997dfb2ad7af8e3025e19e72f53
|
||||
|
||||
pkgname = spot-client
|
||||
|
|
17
PKGBUILD
17
PKGBUILD
|
@ -1,8 +1,8 @@
|
|||
# Maintainer: Daniel Peukert <daniel@peukert.cc>
|
||||
_projectname='spot'
|
||||
pkgname="$_projectname-client"
|
||||
pkgver='0.1.10'
|
||||
pkgrel='4'
|
||||
pkgver='0.1.11'
|
||||
pkgrel='1'
|
||||
pkgdesc='Gtk/Rust native Spotify client'
|
||||
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
||||
url="https://github.com/xou816/$_projectname"
|
||||
|
@ -11,21 +11,12 @@ depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
|
|||
optdepends=('org.freedesktop.secrets')
|
||||
makedepends=('cargo' 'meson>=0.50.0')
|
||||
checkdepends=('appstream-glib')
|
||||
source=(
|
||||
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
|
||||
"$pkgname-$pkgver-$pkgrel-meson-test-release.diff::$url/commit/2dc722595e6bf716e46b779db6c8d3e239052ff2.diff"
|
||||
)
|
||||
sha256sums=('9399ba0673ad32a9e6220eaa220c08fba8d6464adab5018130e5cad8818b0979'
|
||||
'4366433646f05f74cb9cdc23079ad37655e06589cd28ecd3cd156223ff213a95')
|
||||
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
|
||||
sha256sums=('7f35be66edc2391ca80b9b870239b136d5c67997dfb2ad7af8e3025e19e72f53')
|
||||
|
||||
_sourcedirectory="$_projectname-$pkgver"
|
||||
_builddirectory='build'
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$_sourcedirectory/"
|
||||
patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-meson-test-release.diff"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/"
|
||||
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
diff --git a/build-aux/test.sh b/build-aux/test.sh
|
||||
index f8ca912..f3b9e8f 100644
|
||||
--- a/build-aux/test.sh
|
||||
+++ b/build-aux/test.sh
|
||||
@@ -2,10 +2,19 @@
|
||||
|
||||
export SRC="$1"
|
||||
export CARGO_TARGET_DIR="$2"/target
|
||||
-export OFFLINE="$3"
|
||||
+export BUILDTYPE="$3"
|
||||
+export OFFLINE="$4"
|
||||
+
|
||||
+echo $BUILDTYPE
|
||||
+
|
||||
+if [[ $BUILDTYPE = "release" ]]; then
|
||||
+ PROFILE_ARG="--release"
|
||||
+else
|
||||
+ PROFILE_ARG="--verbose"
|
||||
+fi
|
||||
|
||||
if [[ $OFFLINE = "true" ]]; then
|
||||
export CARGO_HOME="$SRC"/cargo
|
||||
fi
|
||||
|
||||
-cargo test --manifest-path "$SRC"/Cargo.toml
|
||||
\ No newline at end of file
|
||||
+cargo test --manifest-path "$SRC"/Cargo.toml "$PROFILE_ARG"
|
||||
\ No newline at end of file
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 93d7387..909e9d6 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -140,6 +140,7 @@ test('Unit tests',
|
||||
args: [
|
||||
meson.source_root(),
|
||||
meson.build_root(),
|
||||
+ get_option('buildtype'),
|
||||
get_option('offline') ? 'true' : 'false'
|
||||
]
|
||||
)
|
Loading…
Reference in a new issue