Update spot-client to 0.1.16
This commit is contained in:
parent
a66e905ac9
commit
bfccd96e88
3 changed files with 8 additions and 41 deletions
10
.SRCINFO
10
.SRCINFO
|
@ -1,7 +1,7 @@
|
||||||
pkgbase = spot-client
|
pkgbase = spot-client
|
||||||
pkgdesc = Gtk/Rust native Spotify client
|
pkgdesc = Gtk/Rust native Spotify client
|
||||||
pkgver = 0.1.15
|
pkgver = 0.1.16
|
||||||
pkgrel = 2
|
pkgrel = 1
|
||||||
url = https://github.com/xou816/spot
|
url = https://github.com/xou816/spot
|
||||||
arch = x86_64
|
arch = x86_64
|
||||||
arch = i686
|
arch = i686
|
||||||
|
@ -20,9 +20,7 @@ pkgbase = spot-client
|
||||||
depends = libpulse
|
depends = libpulse
|
||||||
depends = openssl
|
depends = openssl
|
||||||
optdepends = org.freedesktop.secrets
|
optdepends = org.freedesktop.secrets
|
||||||
source = spot-client-0.1.15-2.tar.gz::https://github.com/xou816/spot/archive/0.1.15.tar.gz
|
source = spot-client-0.1.16-1.tar.gz::https://github.com/xou816/spot/archive/0.1.16.tar.gz
|
||||||
source = disable-clippy-test.diff
|
sha256sums = da9ca8d1c29d8e88bac630e25a07c9682d61ebf8ac61db77ee50db3f4adc3a40
|
||||||
sha256sums = 55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121
|
|
||||||
sha256sums = ebf64746a9fff1242bdbf47736c78aaf7c3c94ef6423002662dbbb74db685004
|
|
||||||
|
|
||||||
pkgname = spot-client
|
pkgname = spot-client
|
||||||
|
|
19
PKGBUILD
19
PKGBUILD
|
@ -1,8 +1,8 @@
|
||||||
# Maintainer: Daniel Peukert <daniel@peukert.cc>
|
# Maintainer: Daniel Peukert <daniel@peukert.cc>
|
||||||
_projectname='spot'
|
_projectname='spot'
|
||||||
pkgname="$_projectname-client"
|
pkgname="$_projectname-client"
|
||||||
pkgver='0.1.15'
|
pkgver='0.1.16'
|
||||||
pkgrel='2'
|
pkgrel='1'
|
||||||
pkgdesc='Gtk/Rust native Spotify client'
|
pkgdesc='Gtk/Rust native Spotify client'
|
||||||
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
|
||||||
url="https://github.com/xou816/$_projectname"
|
url="https://github.com/xou816/$_projectname"
|
||||||
|
@ -11,23 +11,12 @@ depends=('alsa-lib' 'glib2' 'gtk3' 'libhandy' 'libpulse' 'openssl')
|
||||||
optdepends=('org.freedesktop.secrets')
|
optdepends=('org.freedesktop.secrets')
|
||||||
makedepends=('cargo' 'meson>=0.50.0')
|
makedepends=('cargo' 'meson>=0.50.0')
|
||||||
checkdepends=('appstream-glib')
|
checkdepends=('appstream-glib')
|
||||||
source=(
|
source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
|
||||||
"$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
|
sha256sums=('da9ca8d1c29d8e88bac630e25a07c9682d61ebf8ac61db77ee50db3f4adc3a40')
|
||||||
'disable-clippy-test.diff'
|
|
||||||
)
|
|
||||||
sha256sums=('55fa29d3627b8e6218b6a0f927391887fbb1a496b597a74a3af70b75207f4121'
|
|
||||||
'ebf64746a9fff1242bdbf47736c78aaf7c3c94ef6423002662dbbb74db685004')
|
|
||||||
|
|
||||||
_sourcedirectory="$_projectname-$pkgver"
|
_sourcedirectory="$_projectname-$pkgver"
|
||||||
_builddirectory='build'
|
_builddirectory='build'
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "$srcdir/$_sourcedirectory/"
|
|
||||||
# Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
|
|
||||||
# When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
|
|
||||||
patch --forward -p1 < '../disable-clippy-test.diff'
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/"
|
cd "$srcdir/"
|
||||||
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
|
meson setup --prefix '/usr' --libexecdir 'lib' --sbindir 'bin' --buildtype 'release' --wrap-mode 'nodownload' \
|
||||||
|
|
|
@ -1,20 +0,0 @@
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
|
||||||
index 114c965..cbdfeff 100644
|
|
||||||
--- a/src/meson.build
|
|
||||||
+++ b/src/meson.build
|
|
||||||
@@ -185,14 +185,3 @@ test('Unit tests',
|
|
||||||
],
|
|
||||||
timeout: 60
|
|
||||||
)
|
|
||||||
-
|
|
||||||
-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
|
|
||||||
-test('Clippy',
|
|
||||||
- cargo_clippy,
|
|
||||||
- args: [
|
|
||||||
- meson.source_root(),
|
|
||||||
- meson.build_root(),
|
|
||||||
- get_option('offline') ? 'true' : 'false'
|
|
||||||
- ],
|
|
||||||
- timeout: 120
|
|
||||||
-)
|
|
||||||
\ No newline at end of file
|
|
Loading…
Reference in a new issue